Contacto

CONTACTAR EN CASO DE EMERGENCIAS Móvil +56963679637 - MAIL : CONSULTADBABLOCK@GMAIL.COM
- SOPORTE REMOTO EN BASE DE DATOS ORACLE - ORACLE LINUX - ORACLE VM SERVER - ORACLE RAC - ORACLE DATA GUARD
- UPGRADES - CAPACITACION

Wednesday, June 16, 2010

Como configurar el repositorio Oracle Public Yum

Muchas veces se ha convertido en un verdadero problema saber si están todas las librerías de sistema operativo instaladas para arrancar el runInstaller y terminar una instalación exitosa del motor Oracle. Para automatizar, estandarizar y controlar la instalación del motor Oracle sobre Linux. Oracle dispone de un repositorio público donde se encuentran todos los paquetes necesarios para la instalación y así garantizar un ambiente certificado y con buen funcionamiento basado en todos los prerrequisitos solicitados por Oracle.

El utilitario yum (Yellowdog Updater Modified) es un manejador de paquetes que permite automáticamente actualizar, instalar o eliminar paquetes del sistema operativo. Esto incluye la resolución automática de dependencias y revisión si existen paquetes desactualizados.

Para aprender mas sobre linux:
.- Proyecto Lucas - http://es.tldp.org
.- ejecuta "man yum"



Configurando Yum

Para realizar los primeros pasos de configuración es necesario ingresar al directorio /etc/yum.repos.d. En este directorio se debe dejar el repositorio público que será bajado mediante el utilitario wget.

Es importante tener en cuenta que también se puede bajar un repositorio para la versión Oracle Enterprise Linux 4. Donde se puede encontrar el paquete para la validación de prerrequisitos de instalación para la plataforma.



Una vez bajado el repositorio publico, debemos editarlo para habilitar el "Flag" que nos permitirá bajar todos los paquetes necesarios para nuestra instalación de Oracle.




Para Activar el "Flag" se debe modificar cada uno de los repositorios correspondientes a las actualizaciones hasta llegar a la última versión que se tiene instalada.

El cambio a realizar es el siguiente en el parámetro enabled:

enabled=0 a enabled=1



Grabar el archivo y salir con la opción wq!



El paquete RPM oracle-validated esta encargado de automatizar la instalación de todos los prerrequisitos necesarios para configurar Oracle, ya sea en su versión Standalone o RAC.

Se puede bajar desde el siguiente link para la versión OEL 5:

http://oss.oracle.com/el5/oracle-validated/

Disponible también para la versión OEL 4:

http://oss.oracle.com/el4/




Una vez seleccionado el paquete para la version de sistema operativo, es necesario guardarlo en un directorio definido para su almacenamiento.







Para iniciar el proceso automático de instalación de paquetes, es necesario ejecutar el siguiente comando:

yum install oracle-validated-1.0.0-18.el5.x86_64.rpm



Una vez, que automáticamente se detectaron los paquetes necesarios para instalar y se analizan y resuelven las dependencias. El utilitario permite mediante un pequeño dialogo proceder con la instalación respondiendo lo siguiente:

Is this ok [y/N]: y



Cuando el proceso termina entrega el siguiente mensaje:

Complete!



Mediante esta configuración y procedimiento es posible instalar 10gR2, 11gR1 y 11gR2.

NOTA: Es importante tener en cuenta que no se consideran en este proceso tres paquetes de 32-bit que son necesarias para instalar 11gR1 y 11gR2. En todo caso el instalador de Grid Infraestructure o el instalador de la base de datos 11gR2 es lo bastante inteligente para analizar el sistema e indicar cuales son los tres paquetes que faltan.

Saludos,
Alberto
Viva LINUX!!!!!

6 comments:

Arturo Alejandro said...

Buenisimo...buenisimo... salio todo de pelos viejito, gracias

Jose Aquino said...

Todo al pie de la letra, Muchas gracias por el aporte!!!

Jose Aquino said...

Todo al pie de la letra, muchas gracias por el post!!!

Jose Aquino said...

Todo al pie de la letra, muchas gracias por el post!!!

Saulo Aizprúa said...

Gracias!!

Saulo Aizprúa said...

Excelente ..Brother...